Help with Json/Post Data

Discussion in 'Cracking Discussions & Help Forum' started by Falcon, Sep 15, 2015.

Thread Status:
Not open for further replies.
  1. Falcon

    Falcon Basic Member

    Messages:
    612
    Likes:
    289
    Ratio:
    0.25
    So when I'm trying a bot debug; and I do just normal POST method; everything is in the correct format but once I switch it to Json (json is needed for this config) I'm getting this weirdly formatted post data with a bunch of \ \ \ \ everywhere.


    Here is what I'm trying to output as my Json Post data:

    {"grant_type":"password","password":"<PASS>","session_id":"randomNumbers123","username":"<USER>"}

    Here's what I'm getting: 400 bad request, and my post data looks like this:

    {"{\"grant_type\":\"password\",\"password\":\"<PASS>\",\"session_id\":\"randomNumbers123\",\"username\":\"<USER>\"}":""}


    not output as <USER> or <PASS> just edited to keep info priv8

    thanks for the help
     
  2. Villezzai

    Villezzai Advanced Member

    Messages:
    823
    Likes:
    1,050
    Ratio:
    0.97
    I had exactly same problem yesterday, i really want to know how to solve it.
     
  3. Falcon

    Falcon Basic Member

    Messages:
    612
    Likes:
    289
    Ratio:
    0.25
    I tried using variable, regular post data, everything.. Couldn't fix it.. Saw olaf did though but he didn't respond to my PM. hue
     
  4. Tarwin

    Tarwin Advanced Member

    Messages:
    384
    Likes:
    315
    Ratio:
    3.09
    There's a specific syntax to do it. The problem is that sentry will escape all the " because it's treated as a value and not a field. Ask olaf he knows the syntax
     
  5. Falcon

    Falcon Basic Member

    Messages:
    612
    Likes:
    289
    Ratio:
    0.25
    Ah I figured it out! Thanks
     
  6. Truculent

    Truculent Well-Known Member Retired Staff

    Messages:
    2,878
    Likes:
    1,789
    Ratio:
    0.84
    Fixed!.
     
Thread Status:
Not open for further replies.

Share This Page